headus 3D tools headus 3D tools / 3D scans
Support Forums
 
 FAQFAQ   SearchSearch    UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
headus 3D scans

3DSMax interface script modified
Goto page 1, 2  Next
 
Post new topic   Reply to topic
View previous topic :: View next topic  
Author Message
hayhamLT



Posts: 2
Joined: 05 May 2010

PostPosted: Wed May 05, 2010 2:39 am    Post subject: 3DSMax interface script modified Reply with quote

3DSMax to uvlayout script v3

UV Pipe by Robert Fletcher
Mod by zM TeaM
This is untested, free, beta software. use/edit at your own risk.

Installation

*Drag and Drop the "uvpipe_3_mod_by_hamLT.mzp" file onto your max viewport.
*Restart Max or browse to the scripts folder "C:\Program Files\Autodesk\3ds Max Design 2011\Scripts\uvpipe" and manually run the script "uvPipe_3.ms"
*Go to Customize -> Customize User Interface
*Click the toolbars Tab
*Change the Category to "_UV Layout Tools (by hamLT)"
*Drag the "headus UV layout bridge" action onto your UI or add it to a new toolbar
*Close Customize UI
*Press the new Button
*A box will come up asking for your "UVlayout.exe".

CHANGE LOG:
-----------------------------------------------------------------
11th May 2010
*UVChannel Choicer
*Error Checker

I made some modifications to this Plug-in, maximum adjusting to my work nature.



screen.jpg
 Description:
 Filesize:  44.36 KB
 Viewed:  67166 Time(s)

screen.jpg



uvpipe_3_mod_by_hamLT.zip
 Description:

Download
 Filename:  uvpipe_3_mod_by_hamLT.zip
 Filesize:  6.05 KB
 Downloaded:  10444 Time(s)



Last edited by hayhamLT on Wed May 19, 2010 7:41 am; edited 8 times in total
Back to top
View user's profile Send private message
headus
Site Admin


Posts: 2835
Joined: 24 Mar 2005
Location: Perth, Australia

PostPosted: Wed May 05, 2010 6:56 pm    Post subject: Reply with quote

I split this out of the original 3DSMax script posting so it was easier for people to find.

Phil
Back to top
View user's profile Send private message Send e-mail Visit poster's website
r_knightly



Posts: 74
Joined: 29 Jun 2007

PostPosted: Mon May 10, 2010 11:44 am    Post subject: Reply with quote

please reinstate my Credit and change log and add yourself to it, I've no problems with you using my code and branching but removing my credit looks disrespectful and dishonest.

Im pretty sure your trying to be helpful,l but adding a uv checker and a channel selector isnt grounds for removing my credit comments from my script or crediting yourself totally in the UI


Thanks
Back to top
View user's profile Send private message
headus
Site Admin


Posts: 2835
Joined: 24 Mar 2005
Location: Perth, Australia

PostPosted: Mon May 10, 2010 8:01 pm    Post subject: Reply with quote

I second that!

Phil
Back to top
View user's profile Send private message Send e-mail Visit poster's website
hayhamLT



Posts: 2
Joined: 05 May 2010

PostPosted: Mon May 10, 2010 11:19 pm    Post subject: Reply with quote

I change the log & UI, see first post. Sorry for negligence.
Thnx
Back to top
View user's profile Send private message
r_knightly



Posts: 74
Joined: 29 Jun 2007

PostPosted: Tue May 11, 2010 1:26 am    Post subject: Reply with quote

thank you Smile
I was looking at your code and I noticed you use a bitmap for the checker pattern. are you aware that max can create this for you with one of its built in procedural textures.

eg.

Code:

nNode.material.diffuseMap = Checker()


No need to distribute an extra bitmap
Back to top
View user's profile Send private message
TexeL



Posts: 2
Joined: 13 May 2010

PostPosted: Thu May 13, 2010 11:59 am    Post subject: Reply with quote

Quote:

$.material= standard diffuseMap:(checker()) showInViewport:true


using checker();
using bitmap for btn;

Wink
Back to top
View user's profile Send private message
r_knightly



Posts: 74
Joined: 29 Jun 2007

PostPosted: Fri May 14, 2010 2:31 pm    Post subject: Reply with quote

Smile
Back to top
View user's profile Send private message
stomps



Posts: 27
Joined: 13 Nov 2006
Location: Austin TX USA

PostPosted: Thu May 27, 2010 3:40 pm    Post subject: New UVpipe scropt Unknown System Exception Reply with quote

I just noticed the new script and was excited to try it out. unfortunately I can't get it to run. Can you help me out?

I am getting this error. Unknown System Exception

I am one version behind the latest UVlayout update. Could that be a problem?



uvpipe3.txt
 Description:

Download
 Filename:  uvpipe3.txt
 Filesize:  10.42 KB
 Downloaded:  3242 Time(s)

Back to top
View user's profile Send private message
stomps



Posts: 27
Joined: 13 Nov 2006
Location: Austin TX USA

PostPosted: Thu May 27, 2010 3:44 pm    Post subject: Reply with quote

Ha! seconds after sending the reply I fixed my problem. It seems I need to apply uvs to all three channels before running the plug-in.

basically I applied an unwrap uv modifier to channel 3, collapsed the stack and ran the script.
Back to top
View user's profile Send private message
TexeL



Posts: 2
Joined: 13 May 2010

PostPosted: Fri May 28, 2010 11:36 am    Post subject: Reply with quote

Script Should Add Automatically 3-rd Channel

Code:
polyop.setMapSupport nNode mapChan true


Quote:
I am getting this error. Unknown System Exception


Please Give More Detailed Description For That Error !?!
Back to top
View user's profile Send private message
r_knightly



Posts: 74
Joined: 29 Jun 2007

PostPosted: Thu Jun 03, 2010 12:36 pm    Post subject: Reply with quote

hey if you find bugs with the sending/receiving procedure could you post them in the original thread.
http://www.headus.com/phpbb/viewtopic.php?t=402
Back to top
View user's profile Send private message
nlsinh



Posts: 1
Joined: 12 Mar 2012

PostPosted: Tue Mar 13, 2012 5:34 pm    Post subject: Reply with quote

Thank you!
Back to top
View user's profile Send private message
crux



Posts: 2
Joined: 08 May 2012

PostPosted: Thu May 10, 2012 9:27 pm    Post subject: Reply with quote

i'm getting flipped uvw faces after using this version, which i can't seem to fix. i don't have the same issue with the original uvpipe beta 2
Back to top
View user's profile Send private message
fxzt



Posts: 1
Joined: 08 May 2012

PostPosted: Sat May 12, 2012 8:15 pm    Post subject: Reply with quote

Thank you!
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic All times are GMT - 8 Hours
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group