headus 3D tools headus 3D tools / 3D scans
Support Forums
 
 FAQFAQ   SearchSearch    UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
headus 3D scans

Softimage XSI Plugin
Goto page Previous  1, 2, 3, 4  Next
 
Post new topic   Reply to topic
View previous topic :: View next topic  
Author Message
Lewi



Posts: 61
Joined: 14 Jul 2006

PostPosted: Mon Feb 12, 2007 3:31 pm    Post subject: Reply with quote

Yeah very nice work. This is much appreciated, Cheers and beers for all Very Happy
Back to top
View user's profile Send private message
headus
Site Admin


Posts: 2871
Joined: 24 Mar 2005
Location: Perth, Australia

PostPosted: Tue Feb 13, 2007 2:37 am    Post subject: Reply with quote

Squid, thanks for your work on this! Sounds like its all working now, so I've updated the docs to include your plugin ...

http://www.uvlayout.com/doc/User_Guide:_UVLayout_as_a_Plugin

Phil
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Squid



Posts: 15
Joined: 05 Feb 2007

PostPosted: Fri Feb 16, 2007 1:32 pm    Post subject: Reply with quote

Thanks Phil, my mum will be proud Smile

The uv update plugin part was delayed due to work but i hope to get something out this weekend.

Thanks all for the appreciation.
Back to top
View user's profile Send private message
GrizzleyBear



Posts: 9
Joined: 20 Feb 2007

PostPosted: Tue Mar 06, 2007 5:12 pm    Post subject: Reply with quote

How can you edit the path in which the script it suppose to find the plug-in (uv layout) ?
Back to top
View user's profile Send private message
Locke



Posts: 18
Joined: 31 Jan 2006

PostPosted: Tue Mar 06, 2007 6:16 pm    Post subject: Reply with quote

Grizzley PM'd me stating that he was having trouble using GATOR (requires XSI Essentials or Advanced v.5+) to transfer the UVs generated in UVLayout to his original mesh, so (hoping he doesn't mind) I wanted to post a reply in here so that those who haven't used GATOR before will know how. This doesn't take into account the XSI plugin because I'm a loser and haven't tried it yet. Wink

Using GATOR with UVLayout is incredibly painless. I'll walk you through a simple test scene to see how it works.

In XSI:

1. Let's create a simple poly sphere by going to Get > Primitive > Polygon Mesh > Sphere and up the divisions to 24 and 24.

2. Now let's give it a simple and distinctive UV projection so that we can differentiate it from the UVLayout UVs. Select the sphere and Get > Property > Texture Projection > Unique UVs. Open up the texture editor to see what it looks like.

3. Export the mesh in OBJ format and open it up in UVLayout.

In UVLayout:

4. Let's make one simple cut around the radius of the sphere, drop both halves into the UV editor, flatten them, then arrange and scale them so that they fit within 0,1 space without overlapping. You should have two flat discs in UV space.

5. Click on save and simply overwrite the original file.

Back in XSI:

6. Click on File > Import > OBJ and import your UVLayout mesh using the default settings.

7. Open up an explorer window for easy selection. You should have two objects now - your original sphere and another object named headusOBJexport. Make sure they are occupying the exact same space by clicking on each. A simple way to be sure is to select the headus object and translating it to the side. If you do so, be sure to undo that translation to get it back into the same model space as the original. If you have a complex scene and your original mesh wasn't at 0,0,0, simply line up both objects as best you can.

8. Select your original sphere in the explorer and Get > Property > GATOR. You will now be presented with a picking session to pick the input object. Select the headus object in explorer and right click to end the picking session. The GATOR ppg will now pop up.

9. In the GATOR ppg, click on the Edit Transfer button under the Transfer Properties > Specify Properties section since we only want the UVs. In the ppg that appears, select UVSpace from the drop down list at the top. Click on Transfer/Merge and close it out.

10. With the original sphere selected, open up the texture editor again. It will now appear that the transfer didn't work but I assure you it did. The problem is that you now have two sets of UVs. You can see this by going into the explorer and expanding sphere > Polygon Mesh > Clusters. You should see two sets of UVs - your original and a new one called Sample. You can access the transferred UVs in the texture editor by selecting the second texture projection under the UVs menu at the top.

Voila! You now have your UVLayout UVs on your mesh. You can keep the original UVs if you have a need to or you can simply delete their cluster in the explorer if you don't.
Back to top
View user's profile Send private message
ghib



Posts: 27
Joined: 02 Feb 2007

PostPosted: Sat Jun 30, 2007 3:54 am    Post subject: Reply with quote

Hi Squid, is there any way for your xsiaddon to pause while you choose the load options in UVLayout. hitting 'export' in xsi seems to dive straight into uvlayout.

With the maya plugin you start uvlayout where you choose what load options you want then choosing 'send selected' will open up the mesh.

Not bashing your addon at all as it's invaluable but this would streamline the workflow a little.

thanks
Back to top
View user's profile Send private message
ghib



Posts: 27
Joined: 02 Feb 2007

PostPosted: Fri Jul 27, 2007 1:40 am    Post subject: xsiaddon not working with current uvlayout v1.20.3 Reply with quote

Just thought I'd mention this.

I am able to install the addon for XSI version 5.11; the menu will install but when a mesh is selected and 'Export UV Mesh' chosen. It will run the script but uvlayout won't startup and nothing will happen.

I also tried uninstalling the addon and reinstalling it just to make sure but to no avail. Anyone else experiencing this?
Back to top
View user's profile Send private message
twocust



Posts: 77
Joined: 25 Feb 2006

PostPosted: Sat Jul 28, 2007 9:21 am    Post subject: Reply with quote

ghib,

I think when my settings need fixing, I just close the UVLayout work window,
adjust the settings, and re-send from XSI...but maybe you've already done this.
Takes a little extra second, but well, I'm still very grateful to have the capacity. Wink


twocust
Back to top
View user's profile Send private message
ghib



Posts: 27
Joined: 02 Feb 2007

PostPosted: Tue Jul 31, 2007 1:59 am    Post subject: Reply with quote

Hi twocust, thanks for the input.

I think my problem lies with the xsiaddon itself as I'm able to dump an obj file onto the Headus UVLayout icon on desktop. I have had the addon working in the past and the only thing that has really changed in my setup recently has been to update uvlayout itself.

Which version of uvlayout are you using btw?
Back to top
View user's profile Send private message
twocust



Posts: 77
Joined: 25 Feb 2006

PostPosted: Tue Jul 31, 2007 10:46 am    Post subject: Reply with quote

Hi ghib,

I'm using XSI 6.02 and UVLayout 1.20.3 on both my laptop and desktop and
haven't had an issue. In fact, I don't recall having any problems with previous
versions either (6.01 or 6.0, and all previous UVLayout versions). <scratches head>

Sorry I can't be of further assistance for verification...


twocust
Back to top
View user's profile Send private message
vertisek



Posts: 1
Joined: 01 Aug 2007

PostPosted: Wed Aug 01, 2007 3:49 am    Post subject: Reply with quote

Im having problem with XSI plugin.

procedure:
1. create sphere and select it
2. With sphere selected click on "Headus UVTools" - Export UV Mesh
result:
Uvlayout starts and i can see Uvlayout window and window of "load options" but I can not see window where you rotate your object and work in it. If i open OBJ file directly in UVlayout everything works fine

Am I doing something wrong...please help...
Back to top
View user's profile Send private message
ghib



Posts: 27
Joined: 02 Feb 2007

PostPosted: Fri Aug 31, 2007 6:39 am    Post subject: XSI Plugin only likes default project Reply with quote

I noticed through a bit of trial and error that this current version (V1.0)of the plugin will only work with the default project set to current. Only a little bit of a pain to change it each time I need to send to UVLayout, but enough of a nuisance to be noticable.

Just thought I'd mention this incase it helps anyone else.
Back to top
View user's profile Send private message
Squid



Posts: 15
Joined: 05 Feb 2007

PostPosted: Mon Sep 17, 2007 5:20 am    Post subject: Reply with quote

sorry about the plugin neglect.

a propper rewrite is on this weeks TODO: list so if you want anything specific please let me know.

Smile
Back to top
View user's profile Send private message
ghib



Posts: 27
Joined: 02 Feb 2007

PostPosted: Thu Sep 20, 2007 3:09 am    Post subject: Reply with quote

Hi Squid, this is the best news I've heard for weeks Very Happy

The only two issues I have with the plugin are as mentioned before;

1. Ideal export settings: Exporting to UVLayout would open the app and pause at the 'Set Load Options' window. Then a 2nd button to send the mesh once those options are checked would be perfect.

2. I have a problem where hitting EXPORT in the Headus UVTools within XSI will only open UVLayout if my Active Project is set to XSI_SAMPLES. All other projects if set to active will not work with the plugin.. I'm not sure if this is an isolated problem on my end or whether anyone else is experiencing this.

In an ideal world there would be an option to automate the GATOR step. I'll quite often have set alot of hard edges on my asset and then want to do a few uv tweaks. So as an addendum I'll add;

3. Option to automate GATOR step on Import UV Mesh. This would include the transfer of the uv information from the UVLayout imported mesh onto the originally selected mesh then Freeze Modeling etc to clean up the scene.

Seems like a lot to ask but it was a wish list Smile

Great work on this plugin tho.. I use it practically everyday and it has really helped. Thanks
Back to top
View user's profile Send private message
Squid



Posts: 15
Joined: 05 Feb 2007

PostPosted: Thu Sep 20, 2007 7:05 am    Post subject: Reply with quote

I've moved the obj settings, static import/export folder (to negate always using the current project nastyness) and various other options to the preferences ppg.

Hopefully, simplifying things and making for a smoother ride.

AutoGator was on my list anyways Smile


I no longer have access to xsi 5x adv but that shouldn't be too problematic.

i'll post it up when done.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic All times are GMT - 8 Hours
Goto page Previous  1, 2, 3, 4  Next
Page 2 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group