headus 3D tools headus 3D tools / 3D scans
Support Forums
 
 FAQFAQ   SearchSearch    UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
headus 3D scans

Maya 2012 plugin error

 
Post new topic   Reply to topic
View previous topic :: View next topic  
Author Message
larue05



Posts: 3
Joined: 13 Oct 2011

PostPosted: Thu Oct 13, 2011 8:48 pm    Post subject: Maya 2012 plugin error Reply with quote

I read through the other 2012 plugin posts but they didn't describe my problem.

After playing with the Demo version for a week, and having it work with no errors I paid and downloaded iuvlayout-hobby-2.07.01.exe today

I uninstalled the plugin, and uvlayout-demo to do a fresh install with the paid software.

I got the software loaded/registered correctly. I installed the plugin and got all the pieces in the right place. I see the shelf icons.

I click "Info" and get the standard folder doesn't exist error.
So I open uvlayout_open.mel and literally do two things.

1) comment out the incorrect paths.
2) uncomment the correct paths.

Save, restart Maya.

Click "Info" and now all I get is this:

"//Error: Syntax error"

How is this even possible? I edited 4 lines total all involving //

Here is the code, what's wrong?

Code:

//Path to UVLayout
global proc string uvlayout_home()
{
   if( `about -win`)
   {
      // return "C:/Program Files/headus UVLayout v2 Demo";
      return "C:/Program Files/headus UVLayout v2 Hobbyist";
      // return "C:/Program Files/headus UVLayout v2 Professional";
      // return "C:/Program Files (x86)/headus UVLayout v2 Demo";
      // return "C:/Program Files (x86)/headus UVLayout v2 Hobbyist";
      // return "C:/Program Files (x86)/headus UVLayout v2 Professional";
   }
   else
   {
      // return "/Applications/headus-UVLayout-Demo.app";
      return "/Applications/headus-UVLayout-Hobby.app";
      // return "/Applications/headus-UVLayout-Pro.app";
   }
}


I didn't have any problems when I ran uvlayout with the plugin and the demo version for what it's worth.
Back to top
View user's profile Send private message
headus
Site Admin


Posts: 2869
Joined: 24 Mar 2005
Location: Perth, Australia

PostPosted: Thu Oct 13, 2011 8:54 pm    Post subject: Reply with quote

Email me your uvlayout_open.mel file and I'll check it ... maybe some weird unprintable/invisible characters got put in there by your text editor???

Phil
Back to top
View user's profile Send private message Send e-mail Visit poster's website
larue05



Posts: 3
Joined: 13 Oct 2011

PostPosted: Thu Oct 13, 2011 9:00 pm    Post subject: Reply with quote

Sent, I'm online atm too Phil; thanks for quick reply.
Back to top
View user's profile Send private message
larue05



Posts: 3
Joined: 13 Oct 2011

PostPosted: Thu Oct 13, 2011 9:18 pm    Post subject: Reply with quote

Awesome Phil!!

Thanks alot, working with no syntax errors now.

Cheers, and thanks for a great product.
Back to top
View user's profile Send private message
headus
Site Admin


Posts: 2869
Joined: 24 Mar 2005
Location: Perth, Australia

PostPosted: Thu Oct 13, 2011 9:46 pm    Post subject: Reply with quote

Great!

For anyone looking at this in the future, the problem *was* bad characters at the start of the edited MEL file. The image below shows them in a text editor that doesn't hide the unprintable characters.

Phil



bad-characters.jpg
 Description:
Bad characters in MEL file
 Filesize:  31.91 KB
 Viewed:  10695 Time(s)

bad-characters.jpg


Back to top
View user's profile Send private message Send e-mail Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group